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This technical white paper contains frequently asked questions about Word Viewer, the Word Viewer README.DOC file, and troubleshooting tips. 
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Frequently Asked Questions

1.	Q.	What is Word Viewer?

A.	Word Viewer is a program that allows people who do not own Microsoft Word to view and print documents that were created in Word. Word Viewer allows you to read and print Word documents, but it does not allow you to edit them, although you can copy information from the document and activate OLE objects. People who already own Microsoft Word can now share their documents with users who do not own Word by giving them the documents and Word Viewer. Word Viewer can read files created with Word for Windows, versions 1.0 and later, as well as files created with Word for the Macintosh(, versions 4.0 and later.

2.	Q.	How can I get Word Viewer?

A.	This program is available at no charge on the Microsoft forums of major online services (such as CompuServe( and GEnie() the Microsoft FTP server, the Microsoft Download Service (MSDL), Microsoft OnLine, and the “What’s New” heading on the Microsoft Home Page of Microsoft's World Wide Web server. You can also order Word Viewer through the Microsoft Sales Information Center at (800) 426-9400 (in the United States) or (800) 563-9048 (in Canada) for a nominal shipping and handling fee. You are encouraged to copy and distribute Word Viewer to your friends and co-workers as well as to upload it to public electronic bulletin board services.

3.	Q.	How do I obtain technical support for Word Viewer?

A.	While Microsoft Word is a retail software package that includes direct technical support from Microsoft, Word Viewer is freeware, and therefore technical support is limited to the contents of this technical white paper. This technical paper is available via FastTips, on Library 2 in the MSWORD forum on CompuServe, and on the Microsoft World Wide Web server.

� Seq number \r 4 �4�.	Q. 	Can I edit documents with Word Viewer?

A. 	No. However, you can copy information from the document, as well as activate any OLE objects in it, while using Word Viewer. You can edit these objects in their server applications and save the objects to a separate file. For example, if you are viewing a document that contains a Microsoft Excel spreadsheet, you can double-click the spreadsheet, edit it in Microsoft Excel, and save the file under a new name. You can then close the Microsoft Excel object and return to Word Viewer. Note, however, that none of the changes you've made to the Microsoft Excel object will be saved by Word Viewer within the Word document.

� Seq number �5�.	Q. 	Can I copy information from a document opened in Word Viewer?

A.	Yes. You can open a document in Word Viewer, copy information in that document to the Clipboard, and paste that information into another application. However, you cannot paste information from the Clipboard into Word Viewer.

� Seq number �6�.	Q. 	Will Word Viewer automatically open my Word documents when I click on them in File Manager?

A.	When you install Word Viewer, its Setup program checks the Windows registration file to see if there are any applications associated with .DOC files. If there are no associations, Word Viewer Setup registers Word Viewer as the application associated with .DOC files so that when you double-click on a .DOC file in Mail or File Manager, Word Viewer will launch, and the document will be loaded automatically.

� Seq number �7�.	Q. 	Will there be a Macintosh or Windows NT( version of Word Viewer?

A.	Currently there is neither a Macintosh nor a Windows NT version of Word Viewer. However, the 16-bit Windows-based Word Viewer can be installed and will run on a Windows NT machine running on an Intel( 80386 or higher processor. 

� Seq number �8�.	Q. 	Can I set up and run Word Viewer under IBM( OS/2( and WARP operating systems?

A.	IBM's OS/2 and WARP operating systems are unsupported system configurations for Word Viewer.

� Seq number �9�.	Q. 	Can I set up and use Word Viewer on a MIPS( or an Alpha computer running Windows NT?

A.	Word Viewer can run on a MIPS or an Alpha computer running Windows NT; however, you must first run Word Viewer Setup on an Intel 80386 or higher machine running Windows, then manually copy the files to the MIPS or Alpha machine. The table below shows the locations of the Word Viewer files after setup, where Windows indicates your Windows directory (usually, C:\WINDOWS for Windows and C:\WINNT for Windows NT). You should copy these files to the appropriate directories under Windows NT on a MIPS or an Alpha machine.

Filename�      File Size�Location��COMPOBJ.DLL�  102,400 �Windows\SYSTEM��OLE2.DLL�  313,344 �Windows\SYSTEM��STORAGE.DLL�  157,184 �Windows\SYSTEM��VSHARE.386�   14,933 �Windows\SYSTEM��LICENSE.DOC�13,824�Word Viewer directory��README.DOC�16,384�Word Viewer directory��SDV.DLL�  103,904 �Word Viewer directory��TTEMBEDV.DLL�  105,472 �Word Viewer directory��TTEMBEXT.DLL�    5,280 �Word Viewer directory��WORDVIEW.EXE�1,815,040�Word Viewer directory��WRDVIEW6.OPT�N/A�Word Viewer directory��WRDVIEW6.REG�     504 �Word Viewer directory��WWINTLV.DLL�369,152�Word Viewer directory���README. DOC (Included with Word Viewer)

Welcome to Microsoft Word Viewer Version 6.0!

Word Viewer is designed to make it easy to exchange Microsoft Word documents with other people.  It allows you to open, view, and print Word for Windows (version 1.0 or later) and Word for the Macintosh (version 4.0 or later) files. Word Viewer will not allow you to edit a document, however.  If you would like to order the retail version of Microsoft Word, contact the Microsoft Sales Information Center at (800) 426-9400 in the U.S., or contact your local Microsoft subsidiary.  For help in locating your local subsidiary, call the Microsoft International Sales Information Center at (206) 936-8661.

Word Viewer also fully supports copying and pasting, or drag and drop, from any open document.

To jump directly to any topic if you are viewing this document in Word or Word Viewer, double-click on its corresponding page number in the table of contents below.
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�Technical Support for Word Viewer

While Microsoft Product Support Services does not provide direct technical support for no-charge items such as Word Viewer either via phone or CompuServe, there are a number of no-charge options available to you to obtain more technical information about Word Viewer. These options include Microsoft FastTips and the Microsoft Knowledge Base. Because Word Viewer is very similar to Word, information on a particular topic, such as printing from Word, might also be pertinent to Word Viewer. Keep this in mind when you look for technical information to assist you in troubleshooting any Word Viewer issue you may encounter.

Microsoft FastTips

Microsoft FastTips is an automated, toll-free service that provides quick answers to commonly asked technical support questions on key Microsoft products. FastTips also offers a comprehensive library of technical information and access to a faxable catalog of technical white papers and data sheets.

FastTips are available by modem from the Microsoft Download Service (MSDL), which you can reach by calling (206) 936-6735. This service is available 24 hours a day, 7 days a week. The highest download speed available is 14,400 bits per second (bps). For more information about using the MSDL, call (800) 936-4100 and follow the prompts. 

On the Internet, FastTips are located on the Microsoft anonymous FTP server. See “How to Access the FTP Server” section below.

You can have any FastTip mailed or faxed to you from the automated Microsoft FastTips Technical Library, which you can call 24 hours a day, 7 days a week at (800) 936-4100.

CompuServe MSWORD Forum Library 2

Information on the Word Viewer is available in the CompuServe MSWORD forum (GO MSWORD) by downloading the self-extracting file WORDVU.EXE. To establish a CompuServe Information Service (CIS) account, call CompuServe directly at (800) 848-8199.

Microsoft's World Wide Web Server

You can access a variety of Microsoft information sources, including the Microsoft Knowledge Base, via Microsoft's World Wide Web server, http://www.microsoft.com.

Microsoft Knowledge Base

The Microsoft Knowledge Base, the same information source used by Microsoft support engineers, contains thousands of technical and support-oriented articles on Microsoft products, including Word Viewer. There are a number of methods by which you can gain access to the most current Microsoft Knowledge Base articles:

TechNet

TechNet, the Microsoft Technical Information Network, is a technical information subscription service providing valuable technical information about Microsoft products, including the Microsoft Knowledge Base. The subscription service includes 12 monthly updates to the TechNet CD-ROM discs. For TechNet subscriptions or information, call (800) 344-2121, extension 035.

MSKB Forum on CompuServe

To access the Microsoft Knowledge Base on CompuServe, type go mskb at the Go command prompt.

Microsoft FTP Site

The Microsoft FTP anonymous server provides access to the Microsoft Knowledge Base for those users who have access to an FTP program service provider. To access the Microsoft Knowledge Base via the Microsoft FTP site, do the following:

1.	Log on to your Internet account.

2.	At the Internet prompt, type

open ftp.microsoft.com

or use the following IP address:

open 198.105.232.1

3. 	When prompted for a user name, type

anonymous

4.	When asked for a password, type your full electronic mail address (for example, johndoe@test.com). 

5.	Type cd kb to go to the KB subdirectory.

6.	Once you are in the KB subdirectory, download the README.TXT and INDEX.TXT files located in that directory. 

README.TXT contains important information regarding Knowledge Base articles on the Internet FTP server and how to access them. INDEX.TXT contains a list of article titles and article IDs for each article.

Information on Using Microsoft Word Viewer

Microsoft Internet Assistant

Internet Assistant cannot currently be used with Word Viewer to browse hyperlinked documents.  Internet Assistant requires the full retail version of Word to operate. Word Viewer can be registered as an external viewer for most World Wide Web browsers, however. For instructions on how to do this, please see the documentation for your Web browser.

Context Menus

Context, or right-click, menus are not available in Word Viewer.

Fields

Fields cannot be updated in Word Viewer. The latest result of the field is displayed.

Templates and Macros

Templates and macros are not supported in Word Viewer.

Loading Documents from File Manager

Each time you double-click on a document in Windows File Manager, a separate instance of Word Viewer will be launched. To avoid this redundancy, drag and drop the files you want to open from File Manager onto the Word Viewer icon or title bar.

Annotations

To view annotations present in a document, choose Annotations from the View menu. If this menu item is unavailable (dimmed), no annotations are present in the document.  To close the annotation pane, choose View Annotations again.

Full Screen

To remove all screen elements such as menus and scroll bars, choose Full Screen from the View menu.  To restore your menus, click the button on the Full toolbar or press the esc key.

Displaying Pictures

Word for the Macintosh Pictures

Display of pictures contained in Word for the Macintosh documents is currently not supported.  You will instead see a blank box or a box with an “X” through it where the picture would normally display.  When running the Word Viewer under Windows NT, you may also receive an error message stating, “There is not enough memory to display or print the picture.” 

Linked Pictures

Word Viewer cannot display linked pictures that use the \d switch. 'Where the Word document contains a linked picture, Word Viewer will instead display an error message stating that "Word Viewer cannot open the graphics file" and will display a blank box where the picture would normally be.

Printer and Video Driver Problems

If you encounter any problems while printing or displaying Word documents with Word Viewer, you may need to reinstall or update your printer or video driver. Like Word, Word Viewer is much more dependent on printer and video drivers than most applications; therefore, you may encounter printing and displaying problem in Word Viewer that you are not experiencing in another applications. Fortunately, updates for common video and printer drivers are generally available either from your printer or video display card manufacturer, or through the Microsoft Download Service (MSDL), which you can reach by calling (206) 936-6735. For more information about using the MSDL, call (800) 936-4100 and follow the prompts. 

Video Drivers

Often you can determine whether your current video driver is causing a problem with Word Viewer by switching your video driver to the standard Windows VGA driver, which you can do through the Windows Setup program located in the Main program group in Program Manager. Below is a list of known problems with specific video drivers:

Dell( S3 Video Driver

With the Dell S3 video driver version 1.3a or earlier, you may encounter general protection (GP) faults when working with page, column, or section breaks in page layout view. Versions 1.32 and later do not have these problems. For information on obtaining the driver upgrade, contact Dell customer support at (800) 624-9896 or connect to the Dell Bulletin Board Service at (512) 728-8528.

ATI Display Driver

Older versions of the ATI display driver may produce screen  garbage (corruption) when you close a dialog box, select text, or type in the first line of a document. If you have an ATI card with the Mach 32 chipset, you can use ATI driver version 2.1 to resolve these problems. If you have an ATI card with the Mach 8 chipset, use ATI driver version 2.2 or later. For information on obtaining the latest ATI video drivers, call ATI Technical Support at (905) 882-2626 or connect to the ATI Bulletin Board Service at (905) 764-9404.

Printer Drivers

If you encounter any troubles printing with Word Viewer, you should consider updating your printer driver to the latest version. Upgrading your printer driver can be beneficial in general as well.  Below is a list of many of the common printers and the printer driver versions that have been known to work properly:

Printer�Printer Driver�Available from��Hewlett-Packard( (HP() DeskJet( series�DESKJETC.DRV version 3.1 or later; version 5.0 now available�HP at (303) 353-7650��HP LaserJet( 4/4M and 4Si/4SiMX�HPPCL5E.DRV version 1.26 or later; version 1.50 now available.�HP��HP LaserJet III series�HPPCL5E.DRV version 2.1 or later�HP��HP LaserJet II series�HPPCL.DRV version 2.34 or later�HP or Microsoft Download Service (MSDL) at (206) 936�6735��IBM 4019�IBM4019.DRV version 1.30 or later�Lexmark at (606) 232-3000, or the Lexmark BBS at (606) 232 5238��IBM 4029�IBM4029.DRV version 1.30 or later�Lexmark��Epson( 24-pin dot-matrix�EPSON24.DRV version 2.11 or later�Epson America at (800) 922�8911��Epson ESC/P2�ESCP2E.DRV version 2.0 or later�MSDL��Panasonic( 24-pin dot-matrix (KX�P series)�PANSON24.DRV version 2.1 or later�MSDL��HP LaserJet III series�HPPCL5MS.DRV version 2.1 or later�MSDL��Cannot Open Document

If you are having trouble opening complex or multiple documents and you are running SHARE.EXE, you may need to increase the /L and /F parameters in the SHARE line in your AUTOEXEC.BAT file so that the line looks something like this:

c:\dos\SHARE.EXE /L:500 /F:5100

Activating OLE Objects

Word Viewer allows you to activate any embedded OLE objects present in your Word documents provided that the corresponding server is present on your machine.  Any changes made in the object are discarded when the OLE server is closed, however.

Word Viewer Filenames and Locations

To remove Word Viewer, delete the directory you installed Word Viewer into. (Do not delete the first four files on the following list. They are shared with other applications.)

Windows indicates your Windows directory (usually, C:\WINDOWS for Windows and C:\WINNT for Windows NT).

Filename�	File Size�Location��COMPOBJ.DLL�	102,400 �Windows\SYSTEM��OLE2.DLL�	313,344 �Windows\SYSTEM��STORAGE.DLL�	157,184 �Windows\SYSTEM��VSHARE.386�	14,933 �Windows\SYSTEM��LICENSE.DOC�	14,336�Word Viewer directory��README.DOC�	31,744�Word Viewer directory��SDV.DLL�	103,904 �Word Viewer directory��TTEMBEDV.DLL�	105,472 �Word Viewer directory��TTEMBEXT.DLL �	5,280 �Word Viewer directory��WORDVIEW.EXE�	1,815,040�Word Viewer directory��WRDVIEW6.OPT�	N/A�Word Viewer directory��WRDVIEW6.REG�	504 �Word Viewer directory��WWINTLV.DLL�	369,152�Word Viewer directory��OLE Registration/Association

By default, the Word Viewer associates all .DOC and .DOT files with WORDVIEW.EXE.  If you currently have Microsoft Word 6.0 for Windows installed, files with these extensions will remain associated with Word and not Word Viewer.

� Troubleshooting Printing Problems

1.	Q.	Why doesn't background printing work when I print from Word Viewer to my Hewlett-Packard (HP) DeskJet printer?

A.	Word Viewer turns off the Background Printing option and makes the option unavailable when you use certain versions of the HP printer drivers for the HP DeskJet printer. (To locate this option, choose Options from the View menu, and select the Print tab.) Word Viewer does this for the following HP printer drivers because they sometimes fail to print small portions of text when the Background Printing option is turned on:

·	DJ500C.DRV versions 2.x for the DeskJet printer series

·	DESKJETC.DRV version 3.1 for the DeskJet printer series

With Background Printing turned off in Word Viewer, these printer drivers print reliably and lose no text.

2.	Q.	Why doesn't my graphic print in Word Viewer?

A.	Graphics may not print for a variety of reasons, including the following:

1.	You may have an old or incompatible version of your printer driver. You should always print using the latest version of the Windows driver for your printer. To determine your printer driver version, do the following:

a.	From the File menu, choose Print.

b.	Choose the Printer button, then choose the Options button.

c.	Choose the About button. The version of your printer driver should appear in the About dialog box. If there is no About button in the Options dialog box, look for a version number in the Options dialog box, near the OK button.

2.	The Draft Output check box may be selected in the Print Options dialog box. To print graphics, clear this check box by doing the following:

a.	From the View menu, choose Options.

b.	Select the Print tab.

c.	Clear the Draft Output check box and then choose OK.

3.	The Drawing Objects check box may not be selected in the Print Options dialog box. To print drawing objects you created in Word, select this option using the following steps:

a.	From the File menu, choose Print.

b.	Choose the Options button.

c.	Select the Drawing Objects option and then choose OK.

4.	If your graphic is an encapsulated PostScript�symbol 210 \f "Symbol"�� (EPS) file, you must print it to a PostScript printer. If you do not have a PostScript printer, you cannot print an EPS graphic. If you have a PostScript printer, use the following steps to make sure you are using the PostScript printer driver:

a.	From the File menu, choose Print.

b.	Choose the Printer button.

c.	Select your PostScript printer in the Printers list and then choose the Set As Default Printer button.

Note: If your PostScript printer does not appear in the Printers list, you must install the printer driver using the Printers icon in the Windows Control Panel window.

3.	Q.	How can I increase the printing speed of Word Viewer?

A.	Here are four things you can do to increase the printing speed of Word Viewer:

1.	Make sure there is a SET TEMP statement in your AUTOEXEC.BAT file and that it points to a valid directory with at least 2 megabytes (MB) of free disk space.

2.	In Windows Print Manager, choose the High Priority setting to allocate more computer processor time to Print Manager. Your documents print faster, but you must wait longer for the hourglass to disappear in Word when you print.

3.	Make more conventional memory available by doing either or both of the following:

a.	Remove unnecessary device drivers and memory-resident software, such as screen savers and virus-detection software, from your CONFIG.SYS and AUTOEXEC.BAT files.

b.	Maximize both the Word application and all document windows.

4.	From the View menu, choose Options, select the Print tab, and clear the Background Printing check box. When this option is not selected, your documents print faster, but you must wait longer for the hourglass to disappear in Word when you print.

4.	Q.	I am using a Hewlett-Packard (HP) LaserJet IIP with Word Viewer and my envelope does not print or it prints incorrectly. What can I do?

A.	If you are running under Windows version 3.1, choose Print from the File menu, and make sure the printer selected is the IIP, not the Series II. If the Series II is selected, the envelope address prints in the wrong position. To change to a different printer, choose Print from the File menu. Choose the Printer button. Select the IIP printer, and choose the Set As Default button. Choose OK. Choose Close. Choose OK.

5.	Q.	How do I change to a different printer in Word Viewer?

A.	When you switch to a different printer in Word Viewer, you also change the default printer setting for Windows. Use the following steps to switch to a different printer in Word Viewer:

1.	From the File menu, chose Print.

2.	Choose the Printers button.

3.	Select the printer you want to use and then choose the Set As Default Printer button.

Note: If your printer does not appear in the Printers list, you must install its printer driver using the Printers icon in the Windows Control Panel window.

6.	Q.	How do I get my document to print from a different tray on my printer?

A.	Use the following steps to switch to a different paper tray:

1.	From the File menu, choose Page Setup.

2.	Select the Paper Source tab.

3.	Select the printer bin you want to use in the First Page and Other Pages boxes, then choose OK.

7.	Q.	When I try to print, nothing happens. What should I do?

A.	Here are steps to take to find the source of the problem:

  1.	Check the status of your print job in Windows Print Manager. If the print job is stalled, choose the Resume button.

  2.	Try printing a file supplied with Word Viewer, such as README.DOC. If that file prints, the problem may be related to the document.

  3.	If you are printing over a network, make sure your network connection is intact. Check with your network administrator for assistance.

  4.	Rename the WRDVIEW6.OPT file.

The WRDVIEW6.OPT file primarily stores settings that can be found in View Options. However, the WRDVIEW6.OPT also caches some other information about your fonts, printer, and display. Use File Manager to change this file’s name to WRDVIEW6.OLD. When you rename the WRDVIEW6.OPT file, Word Viewer will launch with its default settings, and will create a new “clean” WRDVIEW6.OPT file the next time you exit from Word Viewer. 

  5.	Check to see if the problem exists in other applications.

Try printing sample text in other Windows applications such as Write or Notepad. If the printing problem appears in the other applications, then Word Viewer is not the source of the problem. If the problem exists only in Word Viewer, it is still possible that it is a Windows issue, and not a Word-Viewer-specific issue.

  6.	Check the printer connection.

If the printer is connected directly to your computer, try disconnecting and reconnecting the printer cable, or try another cable. A bad connection or cable may be at fault. If the printer is on a network, see if you can print successfully with a printer connected directly to your computer. If this works, the network is causing the printing problem and you need to contact your network administrator.

  7.	Try a different printer driver.

Be sure you are using the most recent version of the printer driver available from the manufacturer. If none is available, select a similar printer driver, or change the printer’s emulation and choose the matching printer driver.

  8.	Try a different video driver.

Common symptoms of an outdated video driver include missing text or truncated text (the top half is printed, but the bottom half is not). Use the most recent version of the video driver. If a recent version is unavailable, switch to the standard Windows VGA driver using the Windows Setup program located in Program Manager.

  9.	Be sure you’re using a supported printing configuration.

Switch boxes and third-party networks are not supported configurations. Connect the printer directly to the computer, and see if Word Viewer can print. 

10.	Match the printer driver memory setting to the printer’s actual memory.

If the printer driver memory setting is higher than the amount of memory actually available on the printer, you may encounter various printing problems such as dropped text and missing graphics. If you are unsure of the amount of memory on your printer, set the printer driver memory setting to the default.

8.	Q.	How can I get table gridlines to print?

A.	If the original document does not contain table cell borders, you will not be able to print the table gridlines.

Troubleshooting Display Problems

Any of the following screen display problems in Word Viewer may occur because of problems with the video driver supplied with your video card:

1.	Screen distortion, or garbage (such as snow or remnants) may appear when you type or scroll in Word Viewer with certain video display drivers, such as the ATI Ultra. When Word Viewer redraws the screen, the distortion disappears, but it recurs the next time you type or scroll.

2.	The hot spots on the status bar appear to do nothing when you double-click them, even though they are actually functioning normally.

3.	The text and messages on the status bar may be hard to read or may not display at all. For example, when you press the ins key to turn on overtype mode in Word Viewer, "OVR" does not appear on the status bar to indicate that you are in this mode.

If you are experiencing any of the problems described above, contact the manufacturer of your video card and request a new driver. If no new video driver is available, you can use the standard VGA video driver supplied with Windows instead. Change to the standard VGA driver by using the Windows Setup program located in the Main program group in Program Manager. 
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